This document is Microvolution’s Product Reference Manual. This manual will instruct you how to use Microvolution’s Deconvolution Software (plugin for ImageJ), the Blind Deconvolution Option and the Multi-GPU Option.

Contents

1 Product Specifications 3
2 Minimum Requirements 3
3 Installation 4
4 License Management 5
5 Running Deconvolution 7
  5.1 Main tab 7
  5.2 Noise suppression tab 11
  5.3 Advanced tab 13
  5.4 Devices tab 15
6 Pinhole Calculator
   6.1 Spinning disk tab ........................................... 16
   6.2 Airy units tab ............................................... 17
   6.3 Point scanning tab ......................................... 18

7 Troubleshooting .................................................. 19
1 Product Specifications

- Microvolution software provides rapid 2D and 3D deconvolution for fluorescent microscopy images as a plugin for ImageJ or Fiji.
- The software also mathematically generates point spread functions (PSFs) for widefield, confocal, and two-photon microscopes.
- An option can be purchased to enable blind deconvolution.
- This software runs exclusively on NVIDIA graphics cards, see below for requirements.
- An option to utilize multiple graphics cards in parallel can be purchased for certain configurations.
- Very large images can be split into smaller sub-volumes and processed separately if the GPU(s) do not have sufficient memory to process the whole image.

2 Minimum Requirements

- 64-bit operating system
  - Windows 7 or greater
  - OS X 10.11 or greater
  - Linux with GCC 4.6 support (e.g. Ubuntu 12.04, Fedora 16, RHEL/CentOS 7, openSUSE 12.1 or greater)
- NVIDIA graphics card with CUDA capabilities 2.0 or greater
  - Multi-GPU option requires multiple graphics cards
- Up-to-date NVIDIA drivers (minimum version 375)
- Working ImageJ or Fiji installation
  - Minimum ImageJ version 1.48c
- Minimum RAM depends on size of image, but 4+ GB recommended
3 Installation

To install the Microvolution software within Fiji or ImageJ, you will need to move two files into the ImageJ or Fiji application folder on your computer. Note, Microvolution software will not run within a virtual machine.

Copy `microvolution_X_2018.05.jar` into the `plugins` folder of your ImageJ/Fiji installation, where `X` is ‘win’ if you are running Windows or ‘lin’ if you are running Linux.

If an old version of the Microvolution jar is present, delete the old file.

Do **not** delete any files named ‘microvolution.lic’, as these files hold your licenses to run the software. If you are having any problems with your license, please contact us at support@microvolution.com.
4 License Management

To open the license manager and check if an active license has been detected or to activate a new license, go to Plugins → Microvolution → License management in the ImageJ menu bar. To activate your copy of Microvolution deconvolution for the first time, click on “Activate new license” to view the Terms and Conditions (first activation only) and bring up the dialog box below.

![License Management Dialog Box]

1. Host ID of the current computer to which this license is locked. For most users, this will display your 12-character ethernet MAC address. License activation securely transfers this information to the remote activation server.

2. Expiration dates of the deconvolution software and optional add-on modules. This will display ‘permanent’ if you have a perpetual license, an expiration date if you have a short term license, or be blank if no valid license has been found.

3. Revision number of the installed software.

4. Open dialog (below) to activate a new license with a provided activation key.

5. Current version: 2016.03
Enter activation key (in form of 1234–5678–9012–3456). Pressing OK will securely contact the activation server with your computer's host ID and the provided activation key, then save the returned license file in the ImageJ plugins directory. Note that ImageJ must have permissions to write into the ImageJ directory; e.g. on Windows, if ImageJ/Fiji is in C:\Program Files, you may need to run the program as an administrator when activating for the first time to allow the file to be written to disk. You may need to close and reopen the license manager to reload the licenses.
5 Running Deconvolution

To open the deconvolution plugin, go to Plugins → Microvolution → Deconvolution in the ImageJ menu bar.

5.1 Main tab

Choose an open image from the dropdown menu. The chosen image can be a loaded image or a virtual stack of any bit depth. After deconvolution, a new image will be displayed. Note that RGB images must be first converted to a hyperstack (Image → Hyperstacks → Stack to Hyperstack) or RGB stack (Image → Type → RGB Stack).

Number of deconvolution iterations to run per channel. The required number of iterations needed is dependent upon the quality of the image and the desired amount of deblurring. For many images, 10 iterations is a good starting point. If the chosen image is a hyperstack (multiple channels), then selectors for the number of iterations for each channel appear. If the selected image has multiple time points,
then the specified iterations are run for each timepoint. To skip a channel (e.g. transmitted light), set this parameter to 0.

Help correct for high background levels by including the background as an optional parameter in the deconvolution algorithm. In particular, this parameter should be set if a dark “ring” appears around regions of bright fluorescence after deconvolution. When choosing a percentage background (see options in list below), the software automatically chooses the selected percentile of the entire image. When ‘Manual’ is selected, a new set of fields appears in where a precise background level can be specified for each channel. Note that if the background level is set too high, low intensity signals may be suppressed or disappear.

- None
- 1%
- 5%
- 10%
- 25%
- Manual

Detected dimensions for the image specified in . Check these values when loading an image for the first time, as some file loaders and other plugins can incorrectly convert a Z stack into a time series (T stack). ImageJ internally treats RGB images as fundamentally different, so these images must be converted to a hyperstack for proper handling.

If “Generate PSF” is selected, a theoretical PSF is generated using the parameters specified in the right side panel according to the Fraunhofer diffraction model. If not selected, a PSF image must be provided (see ).

The image spacing parameters. The lateral (XY) spacing and axial (Z) spacing must be specified here in nanometers per pixel/slice. These values are read from the image itself and are converted automatically if the spacing is specified in micrometers. Note that selecting an image from the dropdown forces these two parameters to be reread and the image itself is not modified when these numbers are changed. To set the spacing of the image more permanently, modify the image properties (Image → Properties...).

Two mathematical approximations of microscope diffraction are provided: ‘Scalar’ and ‘Vectorial’. The vectorial model is more accurate than the scalar model, particularly with high NA objectives, and is thus recommended for most circumstances. In addition to the objective’s NA and refractive index, the vectorial model requires knowledge of the
sample's refractive index (8). The scalar model does not include the sample RI as a parameter, and thus cannot account for any refractive index mismatches.

The objective NA is the numerical aperture of the objective used to acquire the image (usually written on the side of the objective). The refractive index parameter should be set to the designed immersion media of the objective, i.e. 1.0 for air objectives, 1.33 for water-dipping objectives, etc. See table below for example values:

<table>
<thead>
<tr>
<th>Objective type</th>
<th>NA</th>
<th>RI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Air</td>
<td>0.6</td>
<td>1.0</td>
</tr>
<tr>
<td>Water</td>
<td>1.0</td>
<td>1.33</td>
</tr>
<tr>
<td>Oil</td>
<td>1.4</td>
<td>1.515</td>
</tr>
</tbody>
</table>

The sample refractive index is required when using the vectorial PSF model (7) and should be matched to the immersion medium of the sample, e.g. 1.33 for water, etc.

If using light sheet, an additional field for the light sheet illumination NA appears. This parameter is typically not the physical objective NA, but rather the proportion of the back aperture that is filled by the input light; i.e. 10% filled 0.5 NA objective yields 0.05 effective illumination NA.

Illumination type: widefield, confocal, two-photon, and light sheet. If using light sheet, an additional parameter for the effective light sheet illumination NA appears in 8.

Emission wavelength in nanometers (specify excitation wavelength for two photon).

Back-projected pinhole radius in nanometers. This parameter is only used when a confocal PSF model has been specified (9). For microscopes without additional internal magnification, this value is the physical pinhole radius divided by the objective magnification. See Pinhole Calculator, Section 6, page 16).

Run deconvolution using the parameters specified.

Reload the list of images.

Save the number of iterations, objective parameters, and PSF parameters to a text file for later use.

Read and apply the parameters saved by 14. Note that the desired image should be selected (1) before loading the saved parameters.
Close the plugin and clean up some of the system resources used. To fully clear system resources, ImageJ/Fiji may need to be closed.

Select empirical PSF stack for deconvolution. This image should consist of a single (or averaged) sub-diffraction bead, centered in the volume. The PSF does not need to have the same dimensions or spacing as the input image.

Lateral and axial spacing of the image, as in 6.
Lateral and axial spacing of the PSF.
Detected dimensions of the PSF, as with the image in 4.
5.2 Noise suppression tab

In high noise situations, additional noise suppression through regularization or filtering can be turned on.

1. Regularization to suppress amplification of noise and ringing artifacts. Current options:
   - No regularization
   - Total Variation (TV)
   - Entropy

   ‘Entropy’ regularization is a more advanced algorithm than total variation, and is thus recommended over TV. In either case, selecting the ‘Automatic regularization’ checkbox that appears after choosing Entropy or TV is highly recommended.

2. Filtering applied to image before deconvolution. Current options:
   - No filtering
   - Gaussian filter
   - Gaussian filter, applied to image and PSF
• Median filter

To suppress high frequency noise and compensate for any associated loss of high frequency signal, the third option (Gaussian filter image + PSF) is recommended for high noise images.

Filtering applied to image after deconvolution. Current options:

• No filtering
• Gaussian filter
• Median filter
• Sharpening filter

For most users, none of these options are recommended.
Enable blind deconvolution. If blind deconvolution option is not licensed, then this panel is not displayed.

Reduce edge artifacts by adding a padded boundary of the specified number of pixels to the edges in the x, y, and/or z directions. Z padding in particular can give the biggest visual impact (as artifacts in this dimension are visible across the whole slice). This padding is added to both sides of the image. For many images, at most 10 pixels of padding are usually sufficient. Note that increasing the padding, particularly if the dimension is already a power of two, may cause the image to deconvolve slower than otherwise.

Break the input image into smaller sub-volumes for images that are too large to deconvolve directly with the available devices. Tiling artifacts (i.e. lines of different intensity where the sub-volumes meet) are rarely seen, but can be at least reduced by increasing the padding in the same dimension.

Change the data type of newly deconvolved image. This option can be
set to either “32-bit” (i.e. floating point precision) or “Same as input”. Using the latter option will convert the deconvolution output into the same data type as the input, e.g. an 8-bit input will be returned as a new 8-bit image. If the range of the deconvolved data exceeds the limits of the data type (255 for 8-bit, 65535 for 16-bit), the plugin will scale the data down fit within the data type's range. Otherwise, the native 32-bit deconvolved data are rounded without scaling.
5.4 Devices tab

Choose NVIDIA GPU to use for deconvolution. If you have purchased the "Multi GPU" license option, then multiple GPUs can be selected. These devices will run deconvolution in parallel if your image has multiple channels or timepoints.

2. Total amount of GPU RAM in the device. Not all of this memory may be available for deconvolution if the device is also used for graphics display.

3. CUDA capability version of the GPU. Only devices of CUDA capabilities $\geq 2.0$ are supported.
6 Pinhole Calculator

The provided pinhole calculator, found under Plugins → Microvolution → Deconvolution, provides an estimate of the backprojected pinhole radius needed for deconvolution (see Main tab, 5.1).

6.1 Spinning disk tab

Calculator for spinning disk confocals with circular pinhole.

![Pinhole Calculator](image)

1. Objective magnification
2. System magnification (such as 1.5x tube lens)
3. Physical pinhole diameter, in micrometers (e.g. 50 µm pinholes in Yokogawa CSU-X1 confocal)
4. Backprojected pinhole radius, in nanometers
6.2 **Airy units tab**

Calculator for systems reporting the pinhole size in Airy units.

![Pinhole Calculator](image)

1. Airy units
2. Reference wavelength to which Airy units were calculated
3. Numerical aperture (NA) of the objective
4. Shape of the pinhole (circular, square, or hexagonal)
5. Backprojected pinhole radius, in nanometers
6.3 Point scanning tab

Calculator for point scanning confocals.

![Pinhole Calculator](image)

1. Objective magnification
2. System magnification (such as 1.5x tube lens)
3. Physical pinhole diameter, in micrometers
4. Shape of the pinhole (circular, square, or hexagonal)
5. Backprojected pinhole radius, in nanometers
7 Troubleshooting

If the deconvolution algorithm is not performing as expected and your software license/maintenance agreement is up-to-date, please contact your software distributor directly or Microvolution at support@microvolution.com.